Rattle and Hum

When it comes to complicated home theater electronic gear, sometimes the smallest things can cause the biggest problems – even, in some cases, literally the tiniest of objects. I learned that lesson the hard way recently when I ran into yet another major issue with my old subwoofer.

Some of our readers may remember my articles from earlier this year, in which I discussed upgrading my subwoofer to a new, more capable model, after which I discovered that the old subwoofer had a serious electrical defect that both caused it to perform poorly and made it a fire hazard. (When I took it to an engineer familiar with the unit, the amp board in the subwoofer actually started smoking as soon as he ran some test tones through it!)

Cambridge Soundworks P300HD SubwooferReplacing the amp board seemingly fixed that problem, or so I thought. After bringing it back home, I let the subwoofer sit unused for a while as I considered what to do with it next. Should I sell it, or should I try to integrate it into my home theater room as a second subwoofer? Eventually, I decided to attempt the latter. As much as I’m impressed by the new SVS SB-2000 I bought this year, that subwoofer alone has trouble pressurizing a room the size of mine. A second sub in the opposite corner should help with that. Ideally, I’d want two of the same model with equal performance specs, but that’s beyond my budget at the moment. Since I already have this other subwoofer just sitting here collecting dust, why shouldn’t I at least try it? What’s the worst that could happen… I don’t like it and have to disconnect it again?

Resolved to give this a shot, I moved the 70 lb. beast to the back corner of my room, plugged it in and set it up. Immediately upon turning it on, the unit made a very loud, constant humming noise. “Ah crap,” I thought. “I must have an electrical ground loop. This is going to be annoying.” Indeed, it was.

The most common source of an electrical ground loop in a home theater is the cable TV signal feed. The easiest way to troubleshoot this is to disconnect the coax cable from the back of the cable box. I tried this, but it made no difference. I also happened to have an electrical ground loop isolator on hand from a previous problem I’d had back at my old apartment. Unfortunately, that didn’t resolve the issue either.

Reading up on ground loops brought up a host of conflicting advice. Various electronics companies make devices, some rather pricy, that promise to bust the hum. Before I got to that, I wanted to make sure that this was in fact a ground loop at fault. I’d hate to spend the money only to find out that the subwoofer was still defective.

Because I didn’t remember hearing this hum when I brought the subwoofer to be fixed, the first thing I did was to move it out of the back corner and plug it in on the other side of the room, on a separate electrical circuit. The hum was still present, but nowhere near as loud. Boundary reinforcement in the corner must have been emphasizing the noise. I then moved my other subwoofer to the back corner to see if it also exhibited a hum there. When it didn’t, I knew that this wasn’t a simple ground loop. The hum is coming from the old subwoofer itself. I didn’t notice it previously because I was in an unfamiliar environment with other background noise and wasn’t listening for it. That’s good to know, but I still needed to fix the problem.

I contacted the engineer who replaced the amp board earlier and asked his advice. I really didn’t relish the prospect of having to haul this monster up the stairs out of my basement, into my car, and driving it an hour to be fixed again, so I hoped he could help me troubleshoot the problem. He did some research and found that the metal side panels on this model of subwoofer occasionally had a tendency to induce hum in the ribbon cable that extends from the amp circuit board in the bottom up to the volume control knob on top. In order to verify that this is what’s happening here, I’d have to take the subwoofer apart and do some testing.

P300HD Subwoofer Disassembled

PS300HD Amp Board

Inside the amp is a metal shield next to the crossover control that is supposed to keep hum out of the potentiometer. The engineer (we’ll call him “J.”) recommended that I take a piece of copper wire and touch one end to the shield and the other end to one of the metal side panels. This was supposed to ground the side panel and prevent it from acting as an antenna.

PS300HD Amp Metal Shield

Disappointingly, that didn’t do anything. However, the hum stopped dead when I touched the second end of the wire to my bare fingers rather than the panel. My body acted as a ground, and the hum went completely away. We were clearly onto something here. We just had to narrow down the proper way to ground the amp.

J. next suggested that I touch the wire from the metal shield to the main ground lug in the center of the board. Although nothing happened when I touched the screw (bottom of the highlighted area), the hum indeed stopped when I touched the metal hump above it.

P300HD Main Ground

Further, the hum stopped when I touched the wire from the screw to the metal hump. This is strange. As you can see in the photo, the screw is already attached to the hump by a metal tab between them. Any current from one should carry to the other, yet that didn’t seem to be happening.

At this point, J. took a close look at a photo I’d sent him and spotted something I didn’t notice by eye. He advised me to remove and inspect the screw. At first, I still didn’t see anything wrong. Do you?

P300HD Screw

No? How about now?

P300HD Screw with Washer

Would you look at that? There was a small fiber washer attached to the screw. When J. installed the new amp board, he put the wrong screw in. The washer insulated the screw from the metal tab beneath it, which prevented the amp from being properly grounded. I removed the washer, put back the screw, and, miraculously, the aggravating electrical hum went away!

Yes, it was a tiny piece of fiber barely visible to the eye that caused me such a big headache.

P300HD Fiber Washer

I put the subwoofer back together, hooked it up again, and it works fine now.

After all that, was my experiment running two unevenly matched subwoofers worth the effort? The results are a little inconclusive at the moment. I’ll let you know when I’ve put more hours on the new configuration.

14 comments

  1. Thulsadoom

    That’s the real-world equivalent of the best programming bugs… Spend hours and hours looking for something that stops the program working properly… turns out you forgot to set something to true that should be false… 😉 Hours spent, to alter one line of code! Euphoria at success, followed by screaming at how long it took. 😉

    • EM

      Don’t forget the earlier screaming all throughout the process and optionally at the initial discovery of the glitchiness (especially if something that had been working has suddenly ceased).

      • Thulsadoom

        Ahh, those are the days…. 😀 The days I want to quit being a software developer and enjoy being an author/illustrator instead!!

      • Thulsadoom

        Are you saying only white people can program? You don’t know my ethnicity… 😉 Now if you’d said First World Problem, then it might be a legitimate statement. On the other hand, there are also a lot of software developers in developing countries, who will be screaming their heads off at small bugs, because becoming a proficient coder is their way out of poverty. Perspective and context are wonderful things. 😉

    • William Henley

      I think the worst was doing Cobol. Spend hours looking, and it was because you missed a period somewhere, or one of your lines of code started in the wrong column. This required going line by line, column by column over your code with a flat edge (like a ruler).

      I’ve had issues with motherboards with screws. Usually I try to leave screws out from the middle – I try to mount a motherboard with either three or four screws. The reason is because you always have that one card or something, and I have had cards touch the head of a motherboard screw before and cause a short

      I know I have had issues before with washers, but I cannot think of any examples off the top of my head. Any piece of troubleshooting electronics has its own unique challenges, This article was enjoyable – not because I have had this particular issue, but because I knew it was probably going to end up being something small.

      • Thulsadoom

        I wish I could go back to the days before MVC… Gawd… Just give me a program that actually commits to being something, instead of abstracting out so much that nobody can tell what does what without 10hrs back-tracking! 😉

        • William Henley

          Comments, documentation, flowcharts and pseudocode are your friends! It may be annoying in the beginning when you just want to get in and start coding, but in the long run, they save you a TON of headaches

  2. david Batarseh

    When I first setup my atmos setup it wa slacking bass, so I decided I needed an additional mid room subwoofer. After adding the sub, I instantly noticed a weird creaky noise and thought I blew one of my atmos modules. After two days of playing San Andreas and standing ear level to each of my speakers I figured out what the sound was…..my closet door! The added bass caused the slider on the door to shake; causing the noise. I troubleshooted and figured out it would only occur during high bass sections of the film and not my atmos speakers.

  3. William Henley

    I had a weird subwoofer issue a couple of months ago. I was thinking on many shows and movies that the bass was just horrible. Finally on one, I went to turn up the bass on the subwoofer. Went back to watching my movie, and slowly something started to dawn on me. Went back, and the light on the subwoofer was red, not green, which meant that it was not receiving a signal. That’s strange. So started going through my chain. Problem was that my subwoofer cable was not quite as long as advertised, so I had a pretty tight run under the sofa to the sub. The sofa had been kicked, and the cable was caught up on a leg, so it had caused the cable to seperate from the plug. But it wasn’t a clean pull, at first look, the cable might appear to be fine until I got some light back there. For the replacement I ended up ordering a cable that had about 10 feet extra length on it to give me slack.

Leave a Reply to Thulsadoom Cancel reply

Your email address will not be published. Required fields are marked *